Reverse engineering the Instrutech IGM-400

Every fusor and fusion system seems to need a vacuum. This area is for detailed discussion of vacuum systems, materials, gauging, etc. related to fusor or fusion research.
Post Reply
Lukas Springer
Posts: 15
Joined: Sat Mar 03, 2018 9:37 pm
Real name: Lukas Springer
Contact:

Reverse engineering the Instrutech IGM-400

Post by Lukas Springer » Thu Mar 08, 2018 10:05 am

Hello!

Aren't we all just looking for cheap high vacuum gauges?
Many of you might have stumbled upon the Instrutech IGM-400 "hornet" hot cathode ionisation gauge on ebay, often going for less than 20 USD.
So, what can you do with one of those gauges? A lot as it turns out!
I ordered a couple for reverse engineering and by now I've got them mostly figured out.

Pin No: Function: Note:
1 Sensor on/off Connect this pin to power ground to turn the sensor on
2 Power Ground
3 Voltage output P(mBar) = 10^(Vout-10)
4 Power in 20-28V, 1.5A
5 Not sure yet, but I think Voltage out for one of the Piranis
6 Not sure yet, but I think Voltage out for one of the Piranis
7 Analog Ground do NOT use this ground for switching the sensor or emission current!
8 Emission Current connect this to power ground to change the emission current from 100 µA to 4 mA
9 Sensor Status Open collector transistor to ground, transistor on = sensor on, transistor off = sensor off (50mA max)

Using pin 7 for switching the sensor or current will result in a failure of your gauge, that's how I killed my first two...
Do not turn on the sensor if you are above 1e-2 mbar (100 µA) or 1e-3 mbar (4 mA).
If you're going to build a controller yourself keep in mind that many Sub-D 9 cables are for serial communication and have a couple of pins swapped.

Ask away if you have any questions :)

Lukas

Jonathan Schilling
Posts: 9
Joined: Tue Aug 30, 2016 7:33 pm
Real name: Jonathan Schilling

Re: Reverse engineering the Instrutech IGM-400

Post by Jonathan Schilling » Sun May 20, 2018 4:34 pm

Nice work!

Have you checked out the user manual (http://www.instrutechinc.com/site/files ... l_V116.pdf)?
A quick search revealed the pinout with description on page 17,
i.e. pin 5 and 6 are degas status and degas control.

Cheers,
Jonathan

Lukas Springer
Posts: 15
Joined: Sat Mar 03, 2018 9:37 pm
Real name: Lukas Springer
Contact:

Re: Reverse engineering the Instrutech IGM-400

Post by Lukas Springer » Sun May 20, 2018 6:49 pm

Thanks :)

The IGM-402 and 400 don't seem to have exactly the same pinout, since pin 5 and 6 don't act as degas control, I've checked that.
So far I could not capture any digital communication from the 400, so I just assumed the pirani gauges would give an analog output, too, but I haven't got a clue how they would output 2 piranis, degas status and degas control with the given pinout...

Oh, and by the way, if you buy a used unit I suggest swapping out all three electrolytics on the main board, 7/10 of my gauges had bad caps.
They're normal 220uF 35V SMD caps, so they should not be hard to get. Just watch out not to rip off any pads by pulling too hard while desoldering, the caps have a huge thermal capacity!

Lukas

Chris Giles
Posts: 13
Joined: Mon May 14, 2018 10:46 pm
Real name: Chris Giles

Re: Reverse engineering the Instrutech IGM-400

Post by Chris Giles » Tue May 22, 2018 11:14 pm

Hello Lukas.

I found the manual for the IGM 400 is here http://www.instrutechinc.com/site/files ... t_v102.pdf
This is for the newer IGM 402: http://www.instrutechinc.com/site/files ... l_V116.pdf

Oddly the items on eBay say 402 on the back but clearly are the older model without the display. Also they have the connectors for the 2 external CN gauges, which is not shown in the 400 manual.

Did you figure out the connections and get the gauge working?

In the 400 manual it doesn't describe the D-Sub9 connector as it is "proprietary" for connecting to their controller/display module. On the 402 i see the Analog (Female) and Digital (Male) D-sub 9 connectors have the polarity of the power supply reversed (pins 2, 4) ! The 400 has one Male connector. Surely they would keep the supply polarity the same on the old and new male connectors in case these got swapped. However, I guess the other signals are those which are on the 402 analog port. I wonder if the 400 has an ADC in it and includes digital serial o/p or if the digital circuit is in the controller box?

I'd like to know if it is possible to get these working without the controller with at least log-linear voltage o/p. Although dirt cheap, the international postage makes it add up.

Regards
Chris

Lukas Springer
Posts: 15
Joined: Sat Mar 03, 2018 9:37 pm
Real name: Lukas Springer
Contact:

Re: Reverse engineering the Instrutech IGM-400

Post by Lukas Springer » Thu May 24, 2018 9:25 am

Yes, I did figure out how to use these gauges without an controller, that's what the first post here is about.
The gauges have ha "proprietary" output pinout, with a loglin output voltage, everything I know is in the post.
All of my gauges say "402" on the back, too, and I don't know what's up with that. They are build with modular PCBs and one connector is unused, perhaps the 402 just has a different I/O board and the display on the unused port, but that's just an assumption.

This weekend I might be able to post teardown photos.

Bruce Meagher
Posts: 106
Joined: Fri May 13, 2011 3:25 am
Real name: Bruce Meagher
Location: San Diego

Re: Reverse engineering the Instrutech IGM-400

Post by Bruce Meagher » Thu May 24, 2018 10:42 pm

I ordered three of these gauges. One works as Lukas describes but the other two failed. I need to replace the electrolytic capacitors to see if this is the issue. The pressure output on the working gauge matched my Inficon gauge closely. The voltages are different in the picture below because the two gauges use a slightly different formula to calculate pressure (the pressure was about 1.5E-6 torr).

I did notice if the pressure was below 1E-5 torr before starting the gauge the status led would sometimes blink indicating an error (the pressure output voltage stayed at 10V). If I changed the emission current select to 4mA is usually worked.

Thanks for sharing!

Bruce
Attachments
IMG_0932.JPG

Lukas Springer
Posts: 15
Joined: Sat Mar 03, 2018 9:37 pm
Real name: Lukas Springer
Contact:

Re: Reverse engineering the Instrutech IGM-400

Post by Lukas Springer » Fri May 25, 2018 8:11 am

Thanks for confirming my results!

I do have some issues with starting them at low pressures, too, but there is no mention of anything like that in the manual.
Maybe the sensors off ebay are somewhat broken?
They should all have two filaments, but on all of my gauges I can measure only one, can you confirm that?
I bought mine from the ebay seller "alamedaauction", did you get yours from someone else?
That way we could compare which seller sells them in what condition.

Lukas

Bruce Meagher
Posts: 106
Joined: Fri May 13, 2011 3:25 am
Real name: Bruce Meagher
Location: San Diego

Re: Reverse engineering the Instrutech IGM-400

Post by Bruce Meagher » Fri May 25, 2018 11:05 pm

I can confirm all three of mine only have one filament. They measured approximately 0.14Ω. I couldn't get a good picture of the inside without destroying one so I cannot tell if these are yttria coated iridium or tungsten filaments. However, looking at the numbering IMG402YBX seems to indicate yttria coated, and the X might mean single filament since the manual with dual has a D in that position. If the capacitor replacement doesn’t fix the other two I’ll probably send them back. Or maybe I’ll sacrifice one so we can get a better look at their ion gauge design.

I used the same eBay seller, and given that only one of the three gauges was working they definitely could be damaged or rejected gauges from somewhere.

Bruce

StefanAkaty
Posts: 1
Joined: Sat Mar 03, 2018 5:58 pm
Real name: Stefan Akaty

Re: Reverse engineering the Instrutech IGM-400

Post by StefanAkaty » Sun Jun 24, 2018 9:34 pm

I can also just encourage you to buy one of these, they are dirt cheap and do so unbelievable well, really surprised!
Thank you really much for that great tip, Lukas, great work ;)

Post Reply