CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

For Short Term Learning Discussions ONLY. This area is for CURSORY questions and connecting with other users ONLY. ALL technical contributions need to be made in the appropriate forums and NOT HERE. All posts are temporary and will be deleted within weeks or months. You should have already search the extensive FAQs in each of the forums before posting here as your question may already be answered.
Post Reply
User avatar
Marco Tosini
Posts: 7
Joined: Fri Oct 21, 2016 7:17 am
Real name: Marco
Location: Milano - Italy

CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Marco Tosini » Wed Jan 11, 2017 10:14 am

Dear Group,

thanks in advance for collaborating.

I have just bought a canberra series 35 plus mca from ebay. i bought it from a professional seller so the item arrived well packed cleaned and working.

I read the manual and decided to change the backup battery, following the suggestion to reset the memory. When i plugged again the adc board again .. .nothing appeared on the crt. after some test, i saw that if i pressed the test button on the monitor board, i could see the test pattern, the canberra logo and two lines with strange characters on the lower part on the crt.

If i press a button i can heard only one click and then nothing happens.

definitely the mca can't work anymore... what shall i do ? do somebody have a cpu board for spare?

my father - who helped me to replaced me the battery, may have touched some ic with solder wiring... maybe could be that problem?

did somebody have a similar problems?

i have no services manual of the series 35 and i could know how to solve that.

Thanks Marco



thanks in advance for collaborating,

Marco

User avatar
Marco Tosini
Posts: 7
Joined: Fri Oct 21, 2016 7:17 am
Real name: Marco
Location: Milano - Italy

Re: CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Marco Tosini » Thu Jan 12, 2017 8:59 am

attachment
Attachments
IMG_20170111_191832.jpg

Jon Rosenstiel
Posts: 1338
Joined: Thu Jun 28, 2001 5:30 am
Real name: Jon Rosenstiel
Location: Southern California

Re: CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Jon Rosenstiel » Thu Jan 12, 2017 4:11 pm

Marko,

Make sure the various boards are fully seated in their respective sockets on the motherboard. (I normally tap them in using a small block of wood and soft face hammer)

I have both the service and operator manuals. Once I find them I'll put them in my Dropbox and post the link here.

Jon Rosenstiel

Jon Rosenstiel
Posts: 1338
Joined: Thu Jun 28, 2001 5:30 am
Real name: Jon Rosenstiel
Location: Southern California

Re: CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Jon Rosenstiel » Thu Jan 12, 2017 5:02 pm

Marco,

Dropbox link to Canberra 35 Plus manuals and schematics...

https://www.dropbox.com/sh/t9b3og7v5tko ... h6eGa?dl=0

Jon Rosenstiel

Daniel Kula
Posts: 1
Joined: Tue Nov 14, 2017 6:57 pm
Real name: Daniel Kula

Re: CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Daniel Kula » Tue Nov 14, 2017 7:06 pm

Dear Jon,

Could you please upload again the schematics for Canberra "Series 35" MCA?
The original link seems to have expired.
I would like to compare boards and circuits of "Series 20" with those of "Series 35".
Thank you very much in advance.

Dan

Jon Rosenstiel
Posts: 1338
Joined: Thu Jun 28, 2001 5:30 am
Real name: Jon Rosenstiel
Location: Southern California

Re: CANBERRA SERIES 35 MCA STARTUP PROBLEM 2017

Post by Jon Rosenstiel » Tue Nov 14, 2017 11:42 pm

Dropbox link to Canberra Series 35 Plus schematics.

https://www.dropbox.com/sh/fw75vox8xnoy ... _Ds-a?dl=0

Jon Rosenstiel

Post Reply