MKS 901p

Every fusor and fusion system seems to need a vacuum. This area is for detailed discussion of vacuum systems, materials, gauging, etc. related to fusor or fusion research.
User avatar
Rich Feldman
Posts: 998
Joined: Mon Dec 21, 2009 11:59 pm
Real name: Rich Feldman
Location: Santa Clara County, CA, USA

Re: MKS 901p

Post by Rich Feldman » Sat Jun 09, 2018 12:57 am

Very late to this party, I just powered up my first MKS 901P. LED comes on red, then changes to green.

Analog output is +9.45 V whether at atmosphere, or me sucking on the hose, or connected to a vacuum spigot on the wall here.
My guess is that the analog output mode is not at factory default state, it's set to emulate some other transducer model that's pegged at full scale for my three test points.

Sounds like RS-232 communication is needed before more progress.

Did confirm that 901P connector pin 1, which they call Transmit, is putting out -4.5 V. That's a normal RS-232 level, as the device Marks time. :-)
I think it corresponds to RxD in a traditional modem connection. Signal direction is from the DCE device (modem) to the DTE device (terminal, computer, or USB converter). It's called RD at both ends. Would be on pin 2 of a DE9 connector at both ends, right? Thanks!
Richard Feldman

Rex Allers
Posts: 237
Joined: Sun Dec 30, 2012 8:39 am
Real name:
Location: San Jose CA

Re: MKS 901p

Post by Rex Allers » Sat Jun 09, 2018 5:06 am

The LED action you describe is correct.

You didn't actually tell us what pins on the 901p connector you are measuring for the analog.

I have gotten three of these. They all have the 3-row 15-pin D connector (like VGA monitors use). I assume yours does too. I haven't seen one yet that wasn't set up to all defaults when I got it. If yours has been set to some other analog output curve, you'll need to get the serial connection working to issue status read commands or to change a setting. (I assume you knew that.)

Here's a pic of the circuit for an adapter that I wired up to connect to the 901p.
901P my cable.png
The top two parts are straight out of the manual. Just to be clear, the left pic of the 15-pin connector is looking into the connector on the sensor. I wired it up just like their picture on the right. For power, I connect to a small 12 V SLA battery (12V 7Ah) and I have a switch in the (+) line so I can turn it on and off.

The list at the bottom probably only applies to what I did. I found a VGA cable and cut off one connector so I had a cable with wires on one end to a female 15-pin that plug into the 901p. The colors are what I learned about the cable after ohming all the pins. On a VGA, pin 9 isn't needed so there's no wire for that. I haven't used the sensor relays yet but I figure the Normally Closed of relay 1 I can probably live without.

Here's a pic of the little board I made for this.
Adapter detail.jpg
For the two pins I provided to measure analog out, they are just like in the circuit diagram, the (+) goes to the 901p pin 5, and the minus to pin 6.

I don't usually use the analog out, but I tried it tonight. I connected a DVM. At atmospheric I saw 8.88 V. On a pump, the serial measurement output said 2 E-2 (20 mTorr) and the voltage was 4.3 V, which matches the default chart in the manual.

To see how your 901p is configured or to change it you'll need to get the serial interface talking. I checked the connections on my adapter board. On the board I've got a 9-pin female connector that plugs into the 9-pin male on the end of a USB-to-Serial adapter cable I am using. So the pins on the female 9-pin of my adapter are wired just as shown. (Pin 1 of the 901p 15-pin is wired to pin 2 of the female 9-pin on my adapter.)

The command to check the analog output emulation is:
@254AO1?;FF
(254 is a broadcast address so should always work.)

Mine returns:
@253ACK30;FF

So is set to '30' which is the factory default.
Rex Allers

User avatar
Rich Feldman
Posts: 998
Joined: Mon Dec 21, 2009 11:59 pm
Real name: Rich Feldman
Location: Santa Clara County, CA, USA

Re: MKS 901p

Post by Rich Feldman » Mon Jul 09, 2018 11:35 pm

Yay! One MKS901P is all better now, after some hand-typed serial communication using Tera Term. That users-manual figure copied by Rex resolves, on close inspection, the proper TD and RD connection to RS-232 port with a DE-9 connector. A voltmeter gave the same answer: when unconnected, each device's serial output line presents a negative voltage.
DSCN0664.JPG
The magic kiss was to send the command @253FD!ALL;FF (restore factory defaults) at 9600 baud. Then the device became communicative. The non-default setting with which it was received is gone for good.

A trial command, @253TST!ON;FF, made the green LED start blinking as expected.

Some ID and status queries were unsurprising, with one exception.
DT? "LOADLOCK"
MD? "901P"
TEM? "2.93E+1" (degrees C)
T? "O" (both sensors are OK)
BD? "NAK160". (What's up with that? Expected to see the baud setting.)

OK, time to read atmospheric pressure.
PR3? "7.61E+2"
PR4? "7.611E+2" (new challenge: how repeatable and continuous is the significand's fourth digit, in a device with FSR of eight decades? )

Analog voltage output was now 8.88 V, right where it should be. Got it down to 8.62 V (around 400 torr) by mouth sucking. (Probably not the wisest experiment, but the KF-16 flange looked pretty clean, and didn't taste so bad.) Missing is my other MKS901P, already plumbed up to a hose that will fit mechanical vacuum spigots at work.

Thanks for the original tip, and development help!
Richard Feldman

Pablo Llaguno
Posts: 60
Joined: Sun Feb 05, 2017 11:00 pm
Real name: Pablo Llaguno

Re: MKS 901p

Post by Pablo Llaguno » Tue Jul 10, 2018 2:52 am

You are not the first to try to see if the transducer works by mouth sucking, a very sophisticated method indeed :D

Bruce Meagher
Posts: 106
Joined: Fri May 13, 2011 3:25 am
Real name: Bruce Meagher
Location: San Diego

Re: MKS 901p

Post by Bruce Meagher » Tue Jul 10, 2018 5:12 am

Rich, try BR? not BD? to get the baud rate.

Ameen Aydan
Posts: 42
Joined: Sun Apr 15, 2018 7:33 pm
Real name: Ameen Aydan

Re: MKS 901p

Post by Ameen Aydan » Thu Aug 23, 2018 10:52 pm

Hello,

I am very bad at anything that comes to computer programing so I apologize if I sound very inexperienced. I remember Andrew Seltzman posting code on this thread. He said that it is possible to use Matlab as a program to properly interpret the signals. I'm imagining that you use the analog output then hook it up with an Arduino that changes it to a language that the computer can understand. Then, you use the Matlab software that has Andrews code written into it and allow it to display the pressure reading. Is this how you would go about using Matlab as a programming platform? Or more importantly, is this what Andrew did when he used Matlab?

I hope this is a good approach to the general direction of being able to read the pressure off an MKS 901p. Is there anything I have gotten wrong? I would really love to know how to program this to use it but I really don't have that much time in my hands right now.

thank you

Post Reply